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Chapter 11  Using Global Editing Features
Global editing is a powerful capability in NASIS.  It lets you change large amounts
of data quickly and easily.  This lesson will introduce you to three global editing
commands: Global Assign, Global Delete, and Global Un-Delete.  This lesson also
demonstrates the calculation feature.

Using Global Assign
With the Global Assign command, you can change all values for a specific data
element in your selected set.  For example, you can change a horizon designation
from H3 to Cd for the same components in all data mapunits, or change the T value
for a group of selected soils.  Global Assign allows you to assign a single value to an
entire selected set of data.  This function differs from the paste option in that Paste
works on the entire row, while Global Assign works on an individual column.

When a particular soil series name is reclassified because of a change in taxonomic
classification criteria or new lab data, it may be useful to query your database for all
occurrences of the component and globally change the classification.  This part of
the lesson demonstrates how to do this.  It also shows how to quickly fill in data for
inclusions that had little or no data when converted from SSSD.

1. On the File menu, select New to clear the edit tables and start a new selected set.
2. On the File menu, choose Select.
3. In the Select Manager, select the query Tutorial - Component name, then read

the Query Description.  It explains what this query is designed to do.
4. Highlight the Component target table.
5. When you are ready to run the query, click Apply.
6. In the Query Parameters dialog, type AGAWAM, and click Apply.
 

 
 
7. A message indicates that twenty-two rows were added to the selected set.  Click

OK.
8. Close the Select Manager by clicking Cancel.
9. On the View menu, select Components then Component.  The Data Mapunit

object table appears, displaying the first data mapunit in the selected set and its
AGAWAM component.

 Note:  The data mapunit shows only one component, but the query loaded 22
rows in the component table.  Remember that you queried for the AGAWAM
component only.  This means that each DMU that contains the AGAWAM
component was loaded, but only the AGAWAM component was loaded for
those DMUs which include it.
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10. Using the horizontal scroll bar, scroll about three-quarters of the way through

the Component table and click the Particle Size value.
11. Scroll vertically through the Data Mapunit table by clicking the vertical scroll

arrows on the far right of the Data Mapunit table.  Notice that some of the
components do not have data and are inclusions converted from SSSD.

 

 
 

 

 

 Note:  To quickly enter values in each of these components you can use Global
Assign.

12. To assign the selected Particle Size value to all other components in the
selected set, highlight the particle size valuecoarse-loamy over sandy or
sandy skeletalthen on the Edit menu, select Global Assign.

Click the scroll arrow to view
component data for each data

mapunit in the selected set
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13. A message indicates that twenty-two records were modified.  Click OK.
 Note:   You can verify this by scrolling through the DMUs. Click Up arrow to

see the list of DMUs. The components that have been changed now have an ‘M’
status in the leftmost column. In the first row, click Down arrow.

14. In the same row, highlight the Subgroup column next.
 Note:  Before you assign the Subgroup value to all records, you need to edit it.

The classification was changed based on new lab data, and recent changes in
Soil Taxonomy.  The new Subgroup should be humic dystrudepts.

15. With Subgroup highlighted, click the Choice button.  An empty choice list
appears.

16. Familiarize yourself with the choice list dialog by reviewing the sample screen
below.
 

 

 

 

 

 
 

 
 
 

17. In the Match on Subgroup field, type humic*udepts, then click the Search
button.  Seven matches are returned, as shown in the sample choice list on the
next page.

18. Highlight humic dystrudepts.
 
 

Total number of
available choices in the

choice list:  2435

Zero choices
displayed when the

list contains more
than one hundred

Type a partial
word and

wildcard here

Returns matches and lists them
above in Selections box
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19. Click Apply to insert the selection into the edit window on the NASIS screen.
20. To globally change all subgroups in the selected set, highlight humic

dystrudepts, then on the Edit menu, select Global Assign.
 

 
 
 Note:  When you are changing a large number of values, this function can take

time.
21. When the editing is complete, a message reports that twenty-two records were

changed.  Every Subgroup value in the selected set was modified.  Click OK.
 Note:  This exercise demonstrates why you need to be particularly aware of

what is in your selected set.  With global editing, you can change large numbers

Highlight a
subgroup

Click Apply to insert the
selection into edit window

Choose
Global
Assign
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of records (most of which you cannot even see) in one click of the mouse button.
You also need to make sure the cursor is on the row with the value you want to
assign.

22. In the same row, highlight the Great Group value, and on the Edit menu, select
Display Choice List.

23. In the Search for field, type *udepts, then click the Search button.
 Note:  Five choices are returned.
24. Highlight dystrudepts, click Apply, then Edit, Global Assign.
25. Again, a message indicates that twenty-two records were modified.  Click OK.
26. Assign the Suborder and Order values from the same row to all components in

the selected set, just as you have with Great Group, Subgroup, and Particle Size.
27. Highlight Taxonomic Class.
 Note:  With the edits you made to the other elements, Taxonomic Class is now

out-of-date.  The Taxonomic Class is a protected field and can only be updated
with the NASIS calculation feature.  Notice the small column labeled S to the
right of Taxonomic Class (pointed out on the screen below).  This field indicates
the method by which the Taxonomic Class was entered.

28. On the Options menu, select Calculate Data Elements.
 
 
 
 

 
 
 
 

 

 Note:  The NASIS Calculation Manager appears (shown below).  This feature
lets you calculate certain data elements whose values are based on entries in

This option automatically
calculates the Taxonomic Class
for all records in the selected set

Status column indicates the method by which Taxonomic Class
was entered for this record.
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related fields.  In the NASIS Calculation Manager you will find a listing of
calculations that can be run against the active table.

 

 
 

 Note:  The only calculation available for the Component table is the Taxonomic
Classification calculation.  It creates the taxonomic classification name using the
subgroup and family classes selected for the component.

29. To calculate all rows in the selected set, select the option to Use all rows
currently loaded, then click Apply.

 Note:  A message indicates that the calculation was successful, click OK.
31.  Look at the new Taxonomic Class value, and also notice that the status column

contains a C, meaning taxonomic class was calculated (shown on the next page).

List of available
calculations for the

current table

Explanation of what
the highlighted

calculation does

Select this option to
calculate all rows in

the table

Select this option to
calculate even the
manually-entered

values



Chapter 11:  USING GLOBAL EDITING FEATURES

(430-739, Version 5.0, Feb. 2001)     11.7

 
 

 
 
 Note:  The status column will have one of two entriesC (calculated) or M

(manual entry)or it will be blank (null value, meaning the field has not been
edited since conversion).  The data element value could be null and the status M
indicating that a field was consciously set to null.

32. You have made all the necessary edits.  Open the Data Mapunit table by clicking
the Up table button.

33. Look at the row status of each data mapunit.  Every record has been modified.
 

 
 

Status indicates taxonomic
class was calculated

Calculated
value

Row status
is modified
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 Note:  If someone else owns some of the data mapunits in your selected set
when you do a Global Assign, NASIS will only perform the operation on the
records you have permission to change.  It will ignore the other records.  If some
of the records in your selected set are locked, that is, someone else loaded them
into their selected set before you did, NASIS will not even attempt the global
editing operation.  You will receive a message indicating that at least one record
is locked and the global operation fails.

 Note:  If after performing a global edit you realize you inadvertently changed
records and need to reverse the action, you have three options:  Clear the
selected set (File menu, New) without saving to the permanent database; exit
NASIS without saving, or; use the De-select command to remove those records
you inadvertently changed.

Using Global Delete and Global Un-Delete
The Global Delete command gives you the capability of deleting large amounts of
data in your selected set.  It works on the current table, that is, the table that contains
the highlight cursor.  In the following scenario, you want to eliminate components
that are less than three percent.  You query your database for components that are
less than three percent, and then perform a global deletion of those components.

1. On the File menu, select New to clear the selected set and start a new one.
 Note:  If you get a message warning that data has been modified, click OK.
2. To run a query to retrieve data for editing, on the File menu, choose Select.
3. In the Query Name field on the Select Manager screen, choose

Tutorial - Delete components  <  x%.
4. Click Apply.
5.  In the NASIS Query Parameters dialog, type 3 for the component percentage,

then click Apply.
 

  
6. A message reports that 171 records were added to the selected set.  Click OK.
7. On the Select Manager screen, click Cancel.
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8. If the Component table is not already open, click the Down table button or
choose the View menu, select Components then Component.

 Note:  The selected set now contains all the data mapunits in the tutorial
database containing a component that comprises less than three percent of the
soil.  Also, only the components that are less than 3% were loaded for each of
the data mapunits, even though the data mapunits may have many other
components.

9. With the cursor in the Component table, select Edit menu, then Global Delete.
 Note:  In NASIS, if your cursor is in a root table, you can easily highlight all

records and use the Delete command to delete them.  However, if the cursor is in
a child table, for example, Component table, you cannot highlight all
components in the selected set; you can only highlight all components in the
current or selected data mapunit.  For child tables, you can use the Global Delete
command to delete all components of all data mapunits in the selected set.

10.  A message reports that 171 of the 171 rows were modified.  Click OK.
11. Look at the row status of the component. (Screen resized and shown below.)
 Note:  The Global Delete action marked all components in the selected set for

deletion, as seen in the row status column.  That means the records would be
deleted from the selected set and the permanent database if you used the Save
command.  However, the save command is disabled in the tutorial database.

 

  
12. Open the Data Mapunit table by clicking the Up table button.  All data mapunits

have been modified.
13. If you make global deletions in error, you can reverse the action by using the

Global Un-Delete command.  Click the Down table button to return to the
Component table.

 Note:  Global Un-Delete will cancel all deletions since the last Save, not just
those items deleted with the Global Delete command, but only for the table in

Components
are now

marked for
deletion in the

row status
column
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which the highlight cursor is placed.  Rows that are marked for deletion in other
tables will still be marked for deletion.

14. Select the Edit menu, then choose Global Un-Delete (as shown on the
following sample screen).

 

  
15. A message indicates 171 rows were modified.  Click OK.
16. Notice the row status of the component records returned to a dashed line, which

indicates existing, unchanged data.
 

 

 Note:  You have now finished this lesson.
 

Row status
returns to

existing,
unchanged

status

Global
Un-Delete
command


