Chapter 13: PRINTING REPORTS

Chapter 13 Printing Reports

With NASIS, you can print many kinds of reports including manuscript style tables,
MUG reports, and NASIS generated interpretations. You do this by simply printing
a standard report. The procedures outlined in this lesson apply to all standard
reports. In later lessons, you will learn about preparing interpretation data for
reports.

Note: The tutorial database is a modified subset of the National database. Not all
reports and queries are functional within the tutorial database. Those shown in
examples are functional.

Building a Complete Selected Set

When you select the Options menu and choose a report to print, NASIS assumes you
have already loaded into the selected set the data you want in your report. Reports
in NASIS are based on data in the selected set. After the data is loaded, choosing a
report and printing it is simply a matter of making selections. The real task is
building the selected set so that it contains the right data. The NASIS Report
Manager provides direction on how to build a selected set for specific reports.

1. Clear the selected set by selecting the File menu and choosing New.

2. On the Options menu, select Standard Reports.

Select Standard Reports
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NASIS Preferences

o
3. On the NASIS Report Manager screen, click the National button to display all
reports owned by the national database.

4. Look at the Report Description in the right column of the Report Manager.
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Explains how to build the
/ reports i selected set for a given report
/

—| | NASIS Report Manager

v

NASTS Site:|NSSC Pangaea 7| Local| Mational Wﬁ:z"gn{;r \/
Report Name: Report Description:
AASHTO and UNIFIED calculations j (This report displays the output of PROPERTIES which m
CORR — Conversion Type 1 calculate a single representative AASHTO and UNIFIED
CORR - Conversion Type 3 classification of each horizon in the selected set. The
CORR - Correlation Errors in Rep DMU values are calculated based on the RY of percent passing
CORR - Correlation Errors in Status the sieves. plasticity index and liquid limits.
CORR - Correlation Type 1 Tt Niste ™ bl 1 Doy 4

o ists the mapunit symbol. comp name. layer depths an.
LORR - Lorrelation Type 2 the ARSHTO and UNIFIED values.
CORR - Correlation Type 3

CORR - Data Mapunit List Tables used in the report are component. chorizon.

CORR - Legend and DMU datamapunit. correlation. and mapunit.
CORR - Legend by Name

CORR - Legend by Name with Notes Print the report in Portrait orientation.
CORR - Legend by Status

Preview ‘ Print ‘ Save fAscii ‘ Cancel | Help |

5. Using the vertical scroll bar in the left column of the Report Manager, scroll
down through the Report Name column. When you find CORR — Mapunit
Correlation History, click it.

6. Read the Report Description.

CORR - Mapunit
Correlation History Report

Ready f
NASIS Site:|NSS[I Pangaea j Local| National VU: gnls‘"
Report Mame: Report Description:
CORR - Legend by Status | [Correlation notes for each mapunit in the selected set. B

CORR - Legend by Symbol ]
CORR — Mapunit Correlation History
CORR - Pedon Description (english)

sorted by legend, mapunit symbol. and the date of each
correlation note.

CORR - Pedon Description (metric) The report prints a final correlation date in the title if
CORR - Series Acreage by MLRA (selected set) a date is shown in the Correlation Date column in the
CORR - Series Data Record legend table: otheruise. the title indicates that the
CORR - Series Extent (selected set) ﬂflnal eorrellpiion ds mel epletes

INTERP — Data Export (Component} Load mapunit(s) and area(s) into the selected set.

INTERP - Data Export (Map Unit) Normally. you will load all mapunits in a legend to create
INTERP - Debug Report a complete correlation history report. Data Mapunits are
INTERP - Interpretive Grouping not required.

INTERP - Landscape Table

Preview Print A Save Ascii Cancel Help

Description and
details about the
report and how to
run it.

7. Currently, there are no data in the selected set, so next you will use the Select
Manager to query the database.

Note: Leave the Report Manager open and move it to a corner of your screen so
you can see the Report Description as you use the Select Manager. The Report
Manager only reports on records in the selected set, so you must load records
prior to reporting.

8.  On the NASIS File menu, choose Select.
9. If Ready to Use is checked, click the box to remove the checkmark.
10. Click Local button to select display tutorial queries.
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11. On the Select Manager, choose Query Name: Tutorial - Soil survey area, all
data.

12. On the target table list, highlight the Area and Legend tables, then click Apply.

11. In the query parameters box, type CANYON* for Area Name and choose
published from the survey status choice list.

= NASTS Select Manager

. i _|Ready for
NASTS Site: NASIS_TUTORTAL v| Local| National| ~ ;o2 Only
Query Name!|Tutorial - Soil survey area. all data 7

Select One or More Target Tables:

5 s gy Parmtrs

Mapunit Area Name MATCHES 'CﬂNYUN%

Correlation :

Data Mapunit Survey Status ‘publlShed ﬂ
Query Descriptior| fipply | Cancel | Help |

iThis query is used by the NASIS tutorial. Use this query to select all
data for a survey area. Select the target tables indicated by the
lesson.

|

Query Text:

'FROM area. OUTER (legend. OUTER (mapunit. OUTER (correlation, OUTER
data_mapunit)))

WHERE area.area_name HMATCHES ? AND

(|

| fpply "Cancel" Help ”

12. Click Apply.

13. A message reports that two rows were added to the Area Table and one row was
added to the Legend Table. Click OK.

~| NASIS Message

2 Rouw(s) fAdded to firea Table
1 Rouw(s) Added to Legend Table

0K Help

14. Close the Select Manager by clicking the Cancel button.
15. On the View menu, select Legends, then click Legend.

16. In the Legend table, scroll to the right and note that Canyon County is a
published soil survey that was correlated in September, 1985.

Note: Because you ran the query with Legend set as a target table, the Mapunit
table (as well as the Correlation table—another Legend object table) is fully

populated. No further data is required to run the Mapunit Correlation History
Report.

(430-739, Version 5.0, Feb. 2001) 13.3



NASIS Getting Started

Correlation
table

If a report required additional table data, such as data mapunits, you could have
run the query with Data Mapunit also highlighted in your target table list.
However, that would have loaded about 132 rows to the Data Mapunit table.
Though unnecessary for this report, the following alternative method of loading
data demonstrates how you can load data for a single data mapunit.

Loading Related Data for Reports

When generating reports, it is advisable to limit your selected set (for the sake of
speed) to the specific data you wish to report. Therefore, you will sometimes use
load related rather than a query to target specific related data.

Click the Down table button.

2. With Mapunit Symbol 2 selected, click the Down Table button again. The

Correlation table opens, as shown below.

| MASIS — MNASIS TUTORTIAL [=1e
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Mapunit
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- 11005002 yes 1030 =
|

With the cursor in the Correlation table, select File, Load Related, then click
Data Mapunit.

A message reports that one row was added to the selected set. Click OK. The
data mapunit you want to print is now loaded into the selected set.

Before you print the report, look at the data mapunit by selecting View menu,
Data Mapunits, and Data Mapunit.

Note: This table is populated with the data for mapunit symbol 2.
Click the Down table button to see the Component.
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Note: Displayed in the Comp

be reported on in the CORR —

Printing a Report

In this part of the lesson, you will

onent table are some of the components that will
Mapunit Correlation History report.

learn to preview a report and send it to a printer or

to your email. The following procedure assumes Xprinter has been configured to
recognize your printer or email address. If it has not, you can still preview the report
on screen. See Appendix C for configuration instructions.

The Report Manager should be open already. Locate it on your screen, and click

in the window to make it active.

Note: If you closed it, click the Options menu, then select Standard Reports.

In the Report Manager, click the National button.

Scroll down and select CORR — Mapunit Correlation History.

Click the Preview button.

NASIS Site:‘NSSC Pangaea

| Local| National

¥ Ready for
Use Only

Report Name:

Report Description:

CORR - Legend by Status
CORR - Legend by Symbol

CORR - Pedon Description (english)

CORR - Pedon Description (metric)

CORR - Series Acreage by MLRA (selected set)
CORR - Series Data Record

CORR - Series Extent (selected set)

INTERP - Data Export (Component)

INTERP - Data Export (Map Unit)

INTERP - Debug Report

INTERP - Interpretive Grouping

INTERP - Landscape Table

CORR - Mapunit Correlation History

N

Correlation notes for each mapunit in the selected set.
sorted by legend, mapunit symbol, and the date of each
correlation note.

The report prints a final correlation date in the title if
a date is shoun in the Correlation Date column in the
legend table: otherwise. the title indicates that the
final correlation is not complete.

Load mapunit(s) and area(s) into the selected set.
Normally, you will load all mapunits in a legend to create
a complete correlation history report. Data Mapunits are
not required.

Preview Print

Save Ascii | Cancel Help
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Note: NASIS begins generating the requested report. This may take a couple of
minutes.

5. The Report Viewer appears, displaying the Mapunit Correlation History report
(shown in Figure 13-1).

| Report Viever |«

Report |- Mapunit Correlation History AAJAAAJAAJAAJ Page§1 °¥§12

Name :

United States Department of Agriculture Page 1 of
Natural Resources Conservation Service 03/08/L

Correlation History for the Published Soil Survey of
CANYON COUNTY, TEST DATA
Final Correlation Completed 09,1085

Current

| |
Symbol} Mazp Unit Name : Status Correlation Motes

| |

2}SU'NDDDK LOAMY FINE SaND Icorrelated

4}PDDTATUGK FINE SANDY LOAM Icnrrelated

S}RIPPDWM FINE SaNDY LOAM Icorrelated

E}SADD MUCEY SILT LOAM Icnrrelated

QiWINDDSKI SILT LOAM icorrelated

|

|

|

|

|

|

|

|

|

|

|

|

|

|

|

| 1DB|MERRTMAC FINE SANDY LOAM, 3 T0|correlated
| |8 PERCENT SLOPES |

| | |

| 10C|MERRIMAC FINE SANDY LOAM, 8 T0|correlated
| |15 PERCENT SLOPES |

| | |

| 14B|SHEEPSCOT SAWDY LOAM, 0 TO 5 |correlated
| |PERCENT SLOPES |

| | |

| 15 | SEARSPORT MUCKY PEAT |correlated
| | |

| 22A|COLTON LOAMY FINE SAND, 0 TO 3|correlated
| |PERCENT SLOPES |

| | |

| 22B|COLTON LOAMY FINE SAND, 3 TO B|correlated
| |PERCENT SLOPES |

| | |

| 22C|COLTON LOAMY FINE SAND, 8 TO |correlated
| |15 PERCENT SLOPES |

|

|

|

| |
2EF|COLTON LOAMY FINE SaND, 15 T |correlated
|50 PERCENT SLOPES

Print|Save|Cancel‘Help

Figure 13-1. Sample Standard Report

7. Use the arrow buttons on the Report Viewer to scroll through the report. When
working with your own data, you might check to see that the report contains the
data you intended to have in the report.

Note: The Report Viewer has a button labeled “Save.” You can use the Save
button to save a copy of a report to a file in plain text (ASCII) format. This is
different from writing a report to a file via the Printer Setup dialog, which writes
a file formatted for a particular type of printer (PostScript or PCL format). The
Save button is often a more useful way to save the report output.

8. If you want to print this report, click the Print button.

Note: Printing in the tutorial is not set up the same as printing from the
application. The NASIS application uses the email specified in the NASIS user
table to direct formatted reports to your email address. Therefore, it is very
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important that your user information is kept up-to-date. The tutorial login
does not have any names in the NASIS user table. It must use the printing

process described below. Refer to Appendix C for information on printing from
the NASIS application.

The NASIS Print Manager appears. Refer to the upper left corner of the dialog
(see sample screen on next page) to determine the printer that is currently set up.

Currently
selected printer

—| NASIS Print Manager
Printer: HP LaserJet 45i/45i MX PostScript on hpdsi

(@ Print ALl Pages Orientation:
_JPrint Pages (@ Portrait

From Page: 17i|”0 Page:le _ILandscape
¥ ¥

Print Printer Setup| Cancel | Help

10. Click Printer Setup.

11.

12.

Indicates system setup for a
specific printer

=] Printer Setup

\
Output Format: | (@ Printer Specific _)Generic (File Only) | P%én

Printer:EHP LaserJet 45i/45i MX PostScript on myreports

Orientation: Scale : Ei 00
] Portrait

.} Landscape Copies: El

fpply ‘ Save | Reset ‘ Cancel ‘ Options... | Install... ‘

Note: If the Setup indicates a generic file location rather than a printer specific
location, Xprinter has not been configured through the Printer Setup function to
recognize your printer. Until HyperHelp Xprinter (commercial software used by
NASIS) is configured to recognize your printers, it will only print to a file, even
if the Printer Setup dialog shows that you are printing to a printer. For
instructions on configuring a printer, refer to Appendix C of this manual.

If the printer is properly setup, click the Print button to send the report to the
printer.

If the action was successful, a message indicates that the report was sent to the
printer. Click OK.

Note: You have finished this chapter.
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